Не поддерживается в данной версии оборудования

Не поддерживается в данной версии оборудования

54-ФЗ Кассы

При выполнении команд драйвер может возвращать ошибку — –12 («Не поддерживается в данной версии оборудования»).

Не поддерживается в данной версии оборудования

Цитируем протокол работы ККМ:

Выполнение метода (команды).

Если значение свойства, используемого методом, не подходит для данного метода (для случаев, когда разные методы используют разные диапазоны свойств), выставляются ResultCode = – 6 и соответствующий BadParam. Если значение свойства подходит методу в принципе, происходит определение типа устройства. После этого, если значение не подходит данной модели, выставляется ResultCode = –12 («Не поддерживается в данной версии оборудования») и соответствующий BadParam.

Т.е., данная команда не поддерживается или этой моделью аппарата, или прошивкой аппарата. Выход — свериться с протоколом работы на предмет соответствия команды и модели оборудования, или обновить прошивку.

 

 

Поиск

Наши партнёры

Наши клиенты

Разделы

О сайте

Информация о кассах и ПО компании АТОЛ (и не только), другом оборудовании для ритейла, о работе с ЕГАИС и 54-ФЗ и ЭВОТОРом.

Свои вопросы и пожелания к материалам можете оставлять в комментариях, или направлять на почту info @ kassa-online.su